Contact Us

Home > Error The > Currently-attached ( Ro): False

Currently-attached ( Ro): False

Contents

But ... [[email protected] ~]# xe sr-introduce name-label= "$NAME" shared= true type=lvmoiscsi uuid=9b1e3711-2d23-cd4a-868f-48be33d6f8f4 9b1e3711-2d23-cd4a-868f-48be33d6f8f4 [[email protected] ~]# for host in $(xe host-list --minimal | tr , " " ); do > pbd=$(xe pbd-create I tried repairing as well, it shows Unplugged.Please help me with this. 1366-279401-1519652 Back to top Rohit Singh Members #2 Rohit Singh 5 posts Posted 26 December 2010 - 03:11 PM Can I suggest you try and work with a single host first to rule out such configuration issues? From the host comman line, just isue th ecommand "xe sr-scan". http://vgadownload.com/error-the/error-the-attached-device-is-not-activated-absinthe.html

To apply it, upload the patch to dom0 and run: $ patch -p0 < 0001-XSO-396-Consider-sr_alloc-during-probe.patch You will need to enter the path to the file to be patched since the patch Citrix, please either do whatever you need to do to switch to the new forum style or at least re-enable edits if it's going to be a long time. 1365-328952-1729908 Back We've created an internal ticket to track the fix for you original issue. If not, you could try to create a PBD: xe pbd-create host-uuid=(UUID-of-host) sr-uuid=a9a1fe49-da70-8391-20ea-951de7a1d670 and if you ar sure of the path that's orrect, you can append device-config:path=/.... (whatever the https://discussions.citrix.com/topic/304065-urgent-the-sr-has-no-attached-pbds/

Currently-attached ( Ro): False

For the second one (the one which I've newly created and where i "dd" the content from the other one to:[[email protected] ~]# xe vdi-list uuid=1ba192d7-e83b-469c-bfc1-725f20df2453 params=alluuid ( RO) : 1ba192d7-e83b-469c-bfc1-725f20df2453 name-label You will, however, need to supply the sm-config:allocation parameter: with attached patch applied [[email protected] ~]# xe sr-probe probe $PARAMS sm-config:allocation=xlvhd [[email protected] ~]# xe sr-probe probe $PARAMS sm-config:allocation=xlvhd You can also add "device-config:devs=/dev/sda3" or whatever the actual device is, if you know it.--Tobias 1366-292757-1577403 Back to top John Smith Members #5 John Smith 5 posts Posted 29 August 2011 one of the SRs may be a bogus copy.

Radek. 1366-292757-1577443 Back to top John Smith Members #8 John Smith 5 posts Posted 29 August 2011 - 12:03 PM Hi Tobias, I have tried the Plug command and it still Now, it complains that it cannot not access the VDI and the sr-scan gives the following result: xe sr-scan uuid=ee7061aa-e639-384c-5379-9baf922acac8Error code: SR_BACKEND_FAILURE_46Error parameters: , The VDI is not available [opterr=Error scanning Please re-enable javascript to access full functionality. Seems that there might be a VDI corruption in there somehow, especially if you can copy it without error, but the SR thinks something is amiss.--Tobias 1365-328952-1729917 Back to top Frank

Otherwise, if you list the SR do you see any PBDs associated with it at all? Logical Volume Mount/activate Error Jump to content Citrix Citrix Discussions Log In Citrix.com Knowledge Center Product Documentation Communities Blogs All CategoriesAppDNAArchived Products (includes End of Life)Citrix CloudCitrix Connector for System CenterCitrix Developer ExchangeCitrix Developer Network All Rights Reserved Privacy & Terms Jump to content Citrix Citrix Discussions Log In Citrix.com Knowledge Center Product Documentation Communities Blogs All CategoriesAppDNAArchived Products (includes End of Life)Citrix CloudCitrix Connector for Several functions may not work.

Several functions may not work. The syntax can be gleaned via "xe help sr-probe". Can you do an "xe sr-list uuid(UUID of teh SR) params-all" and check the VDI list?--Tobias 1366-304065-1628387 Back to top Robb Ottenhoff Members #12 Robb Ottenhoff 34 posts Posted 17 March To collect this, you can use XenCenter or you can run xen-bug-tool from dom0.

Logical Volume Mount/activate Error

Any ideas Sir? http://discussions.citrix.com/topic/291302-unable-to-delete-srs-that-seemed-to-lost-their-pbds/ With any luck, it will redo the VDI mapping in your SR. Currently-attached ( Ro): False Am wondering if the PBD is stale and like you said, if the SCSI ID isn't matching? 1366-304065-1628386 Back to top Tobias Kreidl CTP Member #11 Tobias Kreidl 17,221 posts Posted Xenserver Add Local Storage After trying to repair and detach and re-attach, we are getting the following: "Plugging PBD for s2.********.com" Internal error: Failure("Storage_access failed with: SR_BACKEND_FAILURE_47: [; The SR is not available opterr=SR 98f196ba-c98e-23b8-568d-2eb682e5cacf

this should not have any effect :) . All Rights Reserved Privacy & Terms Jump to content Citrix Citrix Discussions Log In Citrix.com Knowledge Center Product Documentation Communities Blogs All CategoriesAppDNAArchived Products (includes End of Life)Citrix CloudCitrix Connector for Im kind of new into XenServer, I donĀ“t know what to do. I tried repairing as well, it shows Unplugged.Please help me with this. 1361-279400-1519651 Back to top Rohit Singh Members #2 Rohit Singh 5 posts Posted 26 December 2010 - 02:58 PM

Use --partial to override.], 1366-279401-1519654 Back to top Rohit Singh Members #3 Rohit Singh 5 posts Posted 26 December 2010 - 03:48 PM Output of pvs: pvs Couldn't find device with Please select the correct LUN.if I look on the storage tap, I can see the VM's disk's, but can't reattach the target.Can anyone help 1366-312197-1667726 Back to top Anthony Anderson Members After having initiated a snapshot for a VM, the VM got frozen and the process never terminated. Nov 3 12:50:58 localhost SM: [29504] ['/sbin/pvs', '--noheadings', '-o', 'vg_name', '/dev/disk/mpInuse/360014058f3f2d3512944850bd6c4ab9b'] Nov 3 12:50:58 localhost SM: [29504] FAILED in util.pread: (rc 5) stdout: '', stderr: ' Failed to find physical volume

Could this be the issue? 1366-304065-1628400 Back to top Tobias Kreidl CTP Member #7 Tobias Kreidl 17,221 posts Posted 17 March 2012 - 11:22 PM Did you try to do an My skype id is john.mcintire3 - or if you know anyone who can do this. See if you can follow this thread for help with your issue, which may be similar: http://discussions.citrix.com/topic/304065-urgent-the-sr-has-no-attached-pbds/ -=Tobias Go to the full post

Gustavo Leig Members #1 Gustavo Leig 3

I will try with the pool now ...

Please re-enable javascript to access full functionality. parameter and sm-config:allocation=xlvhd to the sr-introduce and pbd-create. The sr-probe is a bit more complicated. I gave up on the upgrade restored a backup taken from XenCenter.

Unfortunately the same PBD problem arises.>xe sr-destroy uuid=3cff6942-4cb1-d6d4-64a7-784847a5fac4>The SR has no attached PBDs>sr: 3cff6942-4cb1-d6d4-64a7-784847a5fac4 (xvm-tools)So I decided to just create the SR's again like I did in the first place>xe sr-create Your sr-probe command is missing an sm-config:allocation argument but we still have an issue that I can reproduce: Creating a thin-provisioned block-based SR: [[email protected] ~]# PARAMS="type=lvmoiscsi device-config:target=10.71.76.188 device-config:targetIQN=iqn.2003-01.org.linux-iscsi.dhcp-cam-lab-169.x8664:sn.b3b8b675081b device-config:SCSIid=360014058f3f2d3512944850bd6c4ab9b" [[email protected] ~]# Run pvs* and *lvs commands and check if there are any LV and PV on your local disk. You will, however, need to supply the sm-config:allocation parameter: with attached patch applied [[email protected] ~]# xe sr-probe probe $PARAMS sm-config:allocation=xlvhd [[email protected] ~]# xe sr-probe probe $PARAMS sm-config:allocation=xlvhd

Seemed to follow deleting a VM. The basic syntax is "xe sr-probe type=(SR type)" where"SR type" is one of{code}cslg ext iscsi lvmohba nfsdummy file iso lvmoiscsi udevequal hba lvm netapp{code}so if it's a local device, it's most Several functions may not work. parameter and sm-config:allocation=xlvhd to the sr-introduce and pbd-create.

All Rights Reserved Privacy & Terms Jump to content Citrix Citrix Discussions Log In Citrix.com Knowledge Center Product Documentation Communities Blogs All CategoriesAppDNAArchived Products (includes End of Life)Citrix CloudCitrix Connector for I used the command xe vdi-forget to remove it in the hope that it would re-appear cleanly.In addition, the content of the VG looks a bit strange to me. There used to be an additional LV with clone in the name which I already deleted using lvremove. The given message may give details useful for >debugging the problem.>message: Db_exn.Uniqueness_constraint_violation("SR", "uuid", "3cff6942-4cb1-d6d4-64a7-784847a5fac4")"xe sr-probe" and "xe sr-update" are not supported by my AOE backend so I couldn't try those commands.I

See if you can follow this thread for help with your issue, which may be similar: http://discussions.citrix.com/topic/304065-urgent-the-sr-has-no-attached-pbds/ -=Tobias 1366-377316-1924628 Best Answer Back to top Gustavo Leig Members #3 Gustavo Leig 3 The given message may give details useful for debugging the problem.message: Failure("Storage_access failed with: SR_BACKEND_FAILURE_46: [ ; The VDI is not available [opterr=Error scanning VDI dd2374b7-5bf2-4f66-bd5c-70880dc3b43e]; ]") 1365-328952-1729911 Back to top Is there any way we could hire you or your team? Please re-enable javascript to access full functionality.

This may take a while... Did you try sr-scan and/or sr-probe to see if the SR shows up? or reboot all the servers and then try re-attach. Error: Scanning SR 'Local storage' - The SR has no attached PBDs Started by Rohit Singh , 26 December 2010 - 02:52 PM Login to Reply 1 reply to this topic

Hide Permalink Si Beaumont added a comment - 2015-11-04 12:14 The sr-introduce command should have had the sm-config:allocation=xlvhd. This lack of being able to edit posts is *REALLY ANNOYING*. All Rights Reserved Privacy & Terms Jump to content Citrix Citrix Discussions Log In Citrix.com Knowledge Center Product Documentation Communities Blogs All CategoriesAppDNAArchived Products (includes End of Life)Citrix CloudCitrix Connector for Several functions may not work.

John Mcintire john.mcintire3 - skype (303) 954-9453 1366-362544-1863783 Back to top Tobias Kreidl CTP Member #6 Tobias Kreidl 17,221 posts Posted 10 March 2015 - 05:52 PM John, I would guess But ... [[email protected] ~]# xe sr-introduce name-label="$NAME" shared=true type=lvmoiscsi uuid=9b1e3711-2d23-cd4a-868f-48be33d6f8f4 9b1e3711-2d23-cd4a-868f-48be33d6f8f4 [[email protected] ~]# for host in $(xe host-list --minimal | tr , " "); do > pbd=$(xe pbd-create host-uuid=$host sr-uuid=9b1e3711-2d23-cd4a-868f-48be33d6f8f4 $PARAMS)